大师公式网,最大的股票公式,股票软件下载站 用户登录  |  用户注册
MACD KDJ 三合一主升浪(源码)
  • 软件大小:0 Bytes
  • 推荐星级:
  • 更新时间:2009-08-02 12:07:06
  • 软件类别: 国产软件 / 通达信公式
  • 软件语言:简体中文
  • 授权方式: 解密版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:   【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/Win2000/WinXP/Win2003/
  • 相关Tags:股票公式 股票软件
  • (2) 67%
    (1) 33%

软件简介

 提醒一下:原版有未来函数,本人对未来函数不持偏见,还是有用的,别忘了所有指标都是为你操作时参考的。

MACD KDJ 三合一主升浪等你拿修改
{SHORT 1 200 10 LONG 1 300 30 MID 1 200 10}

VV:=(HIGH+OPEN+LOW+CLOSE)/4;
DIFF:EMA(VV,SHORT)-EMA(VV,LONG),COLORBLUE,LINETHICK2;{9,18,7}
DEA:EMA(DIFF,MID),COLORYELLOW,LINETHICK2;
J:=3*DIFF-2*DEA,COLORRED;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
{DRAWICON(二次金叉,DEA*0.9,1) ;}
DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;

控盘:=MACD;
STICKLINE(控盘<0 AND 控盘<REF(控盘,1),控盘,0,1,0),COLORWHITE;
STICKLINE(控盘<0 AND 控盘>REF(控盘,1),控盘,0,1,0),COLORBROWN;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;

{KDJ}
HHN:=CONST(HHV(DIFF,100));
HLN:=CONST(LLV(DEA,100));
RC1:=CONST((HHN+HLN)/2);
SS:=(HHN-HLN)/200;
K1:="KDJ.K"(30,5,3)*2-100,COLORGRAY,LINETHICK1;
D1:="KDJ.D"(30,5,3)*2-100,COLORGRAY,LINETHICK1;
J1:="KDJ.J"(30,5,3)*2-100,COLORGRAY,LINETHICK1;
JJ1:="KDJ.J"(9,3,3)*2-100,COLORGRAY,LINETHICK1;

JJ:=JJ1*SS+RC1,COLORMAGENTA,LINETHICK1;
周K:=K1*SS+RC1,COLORGRAY,LINETHICK1;
周D:D1*SS+RC1,COLORGRAY,LINETHICK2;
周J:J1*SS+RC1,COLORGRAY,LINETHICK1;

LOWV:=LLV(LOW,90);
HIGHV:=HHV(HIGH,90);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*200-100,1);
K2:=EMA(RSV,10),COLORWHITE,LINETHICK2;
D2:=EMA(K2,20),COLORYELLOW,LINETHICK2;
月K:K2*SS+RC1,COLOR333399,LINETHICK1;
月D:D2*SS+RC1,COLOR333399,LINETHICK2;
-100*SS+RC1,COLOR333399;
100*SS+RC1,COLOR333399;
 

{点击看本软件截图: 分.析家公 式网 http://www天空上尉与明日世界 ”88gs太空犬 ”com 整理}

下载地址(点击上图是广告黑暗中的孩子们 ,点击下图进入下载地址网页)